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A WORD ABOUT MIBAC
MiBAC is an acronym for Music
Instruction By A Computer and is
pronounced “my back.”

MIBAC MUSIC LESSONS I
SOFTWARE
MUSIC LESSONS I teaches general
music theory concepts that apply to all
instruments. It’s the perfect accompani-
ment to your study of music.

Your MUSIC LESSONS I software
package should include the following
items:

• User Guide. You’re reading it now.
• Reference Manual. A reference to the

drills, menus, preferences, and sound
settings in MUSIC LESSONS I.

• A CD-ROM containing the MUSIC
LESSONS I installation program.

• Serial Number Sticker. Cut out the two
numbers, affix one to the registration
card and mail it back to MiBAC. Affix
the other to the inside of the Manual.
You’ll be asked for the serial number
the first time you run the program.

• Registration card. Be sure to return the
card to be eligible for technical
support and to be informed of updates
and new products from MiBAC Music
Software.

HOW TO USE THIS MANUAL
This manual assumes you’re familiar with
basic Macintosh operating procedures and

terminology. This manual is divided into
four chapters.

Chapter 1. Introduction. What’s New.
Describes the new features in MUSIC
LESSONS I.

Chapter 2. Getting Started. Describes how
to install MUSIC LESSONS I.

Chapter 3. Overview. Contains an
overview of the MUSIC LESSONS I
program.

Chapter 4. Using MUSIC LESSONS I.
Contains a work along tutorial introduc-
ing you to the features of MUSIC
LESSONS I.

SUGGESTIONS ABOUT
USING THE DRILLS
Learning music is a multifaceted process,
in which you gain new skills by building
on old ones, and apply skills gained in
one area to other areas. MUSIC LES-
SONS I stimulates your musical growth
by providing a framework to increase
your knowledge and skills in a systematic
and progressive manner. The table below
suggests one method of organizing your
musical study to take advantage of
MUSIC LESSONS I’s drills. In the
following table, the drills are arranged in
order of difficulty.

CHAPTER 1 - INTRODUCTION
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Another method of organizing your
musical study is to work your way
through the skill levels of one drill,
gaining competency in that area. Then
move to another drill to develop addi-
tional skills.

WHAT’S NEW
We’ve added many new features and
enhancements to MUSIC LESSONS I.
Version 3 requires System 7.5 or later.

All Drills
Toolbars

 Drill toolbar.
 Instruments toolbar.
 Scale Degree Names toolbar.

Help Browser
The help window is now a file browser.
We’ve rewritten all of the help files and
added several new ones. In addition, you
can create your own help files, drop them
in the MUSIC LESSONS I Help folder
and they’ll become part of the program.
Help files can be printed.

Balloon Help
Balloon help is available for all windows,
menus and dialogs.

Progress Reports
The score keeping format has changed.
You can now track scores by date. You
can see the scores you got last Monday,
Wednesday three weeks ago, or any date
you used the program. Progress Reports
created in MUSIC LESSONS I version 1
can be opened in version 3.

Color and Display
The program is now in color and supports
several different screen sizes. You can
customize the color elements used on the
screen.

Instruments
The piano instrument can now be four or
six octaves in range. There are two new
instruments, guitar and alphabet blocks.

Clefs
Tenor clef has been added. There’s a new
Random Clefs dialog where you can
select any combination of two to four
clefs.

Sound
You can use sampled sounds, QuickTime
Musical Instruments, and three MIDI
systems: MiBAC’s built in MIDI routines,
Apple’s MIDI Manager, and Opcode’s
OMS.

Sound Effects
You can choose sound effects for right
and wrong answers. You can create your
own sound effects, drop them into the
Sound Effects folder, and they’ll become
part of the program.

MIDI Sounds
There’s a new Patch Change dialog that
supports several synthesizers including
General MIDI. If your synthesizer isn’t
listed, you can create your own patch list
file, copy the file to the Synthesizer Name
Files folder, and it will become part of the
program.

Note Names
Notes can be called by their alphabet
names A B C, or by their solfege names
Do Re Mi.

Ledger Lines
Question and answer notes can range up
to five ledgers above or below staff. In the
previous version some areas of the
keyboard were “out of bounds.” In version
3 you can use the entire keyboard.

Fast Answer Checking
Fast Answer Checking automatically
checks your answers as soon as all answer
boxes are filled. This creates rapid drills
where you get new questions as fast as
you can answer them.

Strict / Lenient Answers
These two items are found in the Level
menu in the three scales drills. Because
every note can have three enharmonic
names (C = Bz = Dxx) it’s sometimes
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difficult for MUSIC LESSONS I to know
what to call the notes you play. In music
theory the correct spelling of each note is
important. Strict Answers enforces music
theory rules for the names of notes.
Lenient Answers relaxes the rules so you
can just play the notes on the keyboard.
The previous version of MUSIC LES-
SONS I always used strict answers.

Keyboard Popup Menu
In strict answers mode in the three scales
drills, hold the mouse button down on a
piano key, guitar fret, or alphabet block
and a popup menu will appear that lets
you choose the accidental you want.

Preferences
An extensive Preferences dialog allows
you to customize the behavior of the
program.

Reset Scores
Sometimes you get off to a bad start and
just want to start over again. The Reset
Scores dialog lets you reset scores for the
current level of the current drill (Reset
Level), all levels of the current drill (Reset
Drill), or all levels of all drills (Reset All).
Whichever one you choose only affects
scores that have not been saved and will
not change any scores already saved in
your progress report.

Drills
Five Finger Positions
The Five Finger Position drill is primarily
for piano students, but is also a good
introduction to learning the major and
minor scales.

Custom Levels
You can create four custom levels in each
drill by choosing the Set Custom Levels
command from the Level menu. For
example, in the Intervals drill, Custom
Level 1 could be ascending major and
minor thirds, Custom Level 2 could be
descending perfect fourths and fifths,
Custom Level 3 could be ascending and
descending major and minor sixths, and
Custom Level 4 could be descending

major and minor sixth and sevenths. You
can save and open custom levels that you
create.

New Levels of Difficulty
The Level menu for each drill consists of
a main section and a custom section. The
custom section is the same in all drills.
The following levels of difficulty are new.

Note Reading
Ledgers Only
No Accidentals
Single Accidentals
Double Accidentals
Beginning Ledgers
Advanced Ledgers

Circle of Fifths
Random Keys
Show Circle

Five Finger Positions
All Major
All Minor
All Major and All Minor
Key Groups
Ascending Motion
Descending Motion
Ascending and Descending Motion
Random Motion
Beginning Placement
Advanced Placement

Major/Minor Scales
Modes
Jazz Scales

Lenient Answers
Scale Degrees

Use Key Signatures
Solfege Names
Number Names

Intervals
Set First Note
Ascending
Descending
Ascending and Descending

Note Durations
Use Dots
First Beat Subdivision
Second Beat Subdivision
All Beat Subdivisions
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Intervals Ear Training
Set First Pitch
Ascending
Descending
Ascending and Descending

Custom Levels in All Drills
Custom Level 1
Custom Level 2
Custom Level 3
Custom Level 4
Set Custom Levels
Save Custom Levels
Load Custom Levels
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In Getting Started you’ll learn how to
install MUSIC LESSONS I to your hard
disk and have MUSIC LESSONS I play
sounds from your Mac or MIDI synthe-
sizer.

SYSTEM REQUIREMENTS
MUSIC LESSONS I requires System 7.5
or later. When this manual was written the
most recent system version was 9.0.4.
MUSIC LESSONS I works best with a 13
inch or larger color monitor. Although not
required, you may want to connect a
MIDI interface and synthesizer.

INSTALLING MUSIC
LESSONS I
Two types of Central Processor Unit
(CPU) chips are used in Macintosh
computers, the 680x0 series (68000,
68020, 68030, and 68040), and the Power
PC chip. They’re are often called 68K and
PPC chips. Macs that use the 680x0 chips
are the SE, II series, Classic, LC, Centris,
Quadra, and many Performas and
PowerBooks. All Power Macs and some
Performas and PowerBooks use the Power
PC chip.

The MUSIC LESSONS I Installer
program gives you three options for
installing MUSIC LESSONS I.

•MUSIC LESSONS I for both 68K and
PPC Macs. The advantage of this
option is that the same application file
will run on all Macs. The disadvan-
tage is the size of the MUSIC
LESSONS I application because it
contains the code needed for both
types of CPU chips.

•MUSIC LESSONS I for 68K Macs.
Runs on all Macs, but not optimized
for Power Macs.

•MUSIC LESSONS I for Power Macs.
Runs on Power Macs only.

Here’s how to install MUSIC LESSONS
I.

1. Insert the MUSIC LESSONS I CD-
ROM disc.

2. Double click the MUSIC LESSONS I
Installer icon and the following window
will appear.

The popup menu at the top of the window
reads Easy Install. Click the Install button
to install the universal version of MUSIC
LESSONS I that runs on both 68K and
Power Macs.

To install a specific version of MUSIC
LESSONS I click the Easy Install popup
menu and choose Custom Install. Click
the checkbox for the version you wish to
install.

CHAPTER 2 - GETTING STARTED
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Next tell the install program where to put
the MUSIC LESSONS I program on your
hard drive. Click the popup menu in the
Install Location area of the window to
select the location to install the MUSIC
LESSONS I program.

The items in the popup menu above the
Select Folder item represent hard disks. If
you choose a hard disk as the install
location, the MUSIC LESSONS I
program files will be copied to a folder at
the top level of that hard drive. If you
choose Select Folder from the popup
menu you can install MUSIC LESSONS I
program files inside any folder(s) on any
hard drive.

3. Select the version of MUSIC LES-
SONS I that you want to install, select the
location to install to, and then click the
Install button.

4. When the install program is finished,
you’ll find a folder named MUSIC
LESSONS Iƒ on your hard drive at the
location you specified. When you open
that folder it should contain these file and
folder icons.

MUSIC LESSONS I
The application. Double click to run.

MUSIC LESSONS I Help (folder)
Contains the music theory reference files
and instruction files that are displayed in
the MUSIC LESSONS I Help window.
You can create your own help files and
add them to this folder. See page 92.

Synthesizer Name Files (folder)
Contains patch list files for various
synthesizers. Information in these files
describes the layout of the different
sounds available on that synthesizer. If
your synthesizer isn’t listed you can
create a file for it and add it to this folder.
See page 93.

Sound Effects (folder)
Contains sound effects that can be played
after right and wrong answers. You can
create your own sound effects and add
them to this folder. See page 93.

MUSIC LESSONS I Readme
Contains last minute information that
didn’t make it into the manual.

ML Help Editor
Use this application to edit and create
your own help files.

MUSIC LESSONS I ICONS
These icons represent the different file
types used by MUSIC LESSONS I.
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The MUSIC LESSONS I application.
Double click to run.

MUSIC LESSONS I Progress Reports
store your scores and can be located
anywhere on your hard drive.

MUSIC LESSONS I Help files. These
files must be located in the MUSIC
LESSONS I Help for them to be dis-
played in the MUSIC LESSONS I Help
window.

Custom Level files store information for
the four custom levels of one drill. These
files can be located anywhere.

The MUSIC LESSONS I Preferences file
stores customization settings used at
program start up. This file is located in the
Preferences folder in the System Folder.

The ML Help Editor application is used to
edit and create MUSIC LESSONS I Help
files. It’s initially located in the MUSIC
LESSONS I folder but can be anywhere.

OPTIONAL FILES
The following files are not required to run
MUSIC LESSONS I and are not supplied
with the program. However, if you have
them, MUSIC LESSONS I will be able to
use them.

MIDI Manager 2.0.2 (from Apple
Computer)

OMS (Open Music System from

Opcode)

See Part 8, Sound for information on
using these MIDI systems with MUSIC
LESSONS I. See page 96 for information
on how to obtain them.

INSTALLING QUICKTIME
If you are not using MIDI and want the
best sounds from your Mac speaker, we
recommend you use QuickTime Musical
Instruments. The QuickTime extension is
normally installed as part of System 7. An
additional extension, QuickTime Musical
Instruments, contains high quality musical
sounds. QTMI (QuickTime Musical
Instruments) is part of the QuickTime
system software supplied by Apple
Computer.

At the time this manual was written the
latest version of QuickTime was 4.0.
QuickTime is available over the internet,
as well as from many user groups and
Apple dealers. See the Reference Manual,
page 53.

When QuickTime is installed properly, the
following files will be located inside the
Extensions folder in the System Folder.

All Macs

  

Power Macs (above two plus)

If they’re not already there, you’ll need to
install them. The easiest way to install
these files is to drag the icon of the file
you’re installing on top of the icon of
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your System Folder. When the System
Folder icon darkens, release the Mouse
button. A dialog box will appear saying
“Extensions need to be placed in the
extensions folder.” Click OK and it’s
done. Restart your computer.

RUNNING MUSIC LESSONS I
Find the serial number sticker that came
with the program. You’ll need it before
you can run MUSIC LESSONS I. There
are two copies of the serial number. Cut
them out. Affix one to the registration
card, fill out the card, and mail it back to
MiBAC.

Keep the second serial number in a safe
place, like the inside cover of the
manual.

Double click the MUSIC LESSONS I
icon to start the program. When the
following dialog appears, enter your
name, organization, and program serial
number. You will not be asked for the
serial number again unless you reformat
your hard drive or reinstall your system
software.

REMOVING MUSIC
LESSONS I
Removing MUSIC LESSONS I from your
computer is easy. Drag the MUSIC
LESSONS I folder to the trash and empty
the trash.

SETTING UP MAC SOUNDS
MUSIC LESSONS I can play sounds
through your computer’s internal speaker.
You can also connect amplified speakers

or headphones to the sound output port on
the back of your Mac.

Now that you’ve completed the setup, it’s
time to play some notes to make sure
everything works correctly. Choose the
Note Reading drill in the Drill menu.
Make sure that the menu items Use Mac
and Use Sound in the Sound menu are
both checked. Click the Middle C key on
the screen piano and verify that the note
name “C” appears in an answer box.

If QuickTime is installed choose Use
QuickTime from the sound menu and
click Middle C again. Hopefully, you
heard the sounds. If not…

Troubleshooting Mac Sound
• Make sure Use Mac is checked in the

Sound menu.

• Make sure Use Sound is checked in the
Sound menu.

• Make sure the sound volume is turned
up in the Sound control panel.

• If you’re using QuickTime, make sure
the correct files are installed. See page
11.

• Read the FAQ in the Appendix. See the
Reference Manual, pages 48-49.

Chapter 4, Sound, in the Reference
Manual discusses sound in detail.

SETTING UP MIDI
MUSIC LESSONS I can send and receive
MIDI. You’ll need a MIDI interface, a
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MIDI synthesizer, and cables. The
simplest setup uses a MIDI synthesizer
that has its own built in sounds.

A slightly more complex setup uses a
MIDI controller (no sounds of its own)
and a MIDI sound module (has sounds,
but doesn’t have keys). With this setup,
you’ll need to enable Use MIDI Echo on
the MIDI Setup page in the Preferences
dialog. See the Reference Manual, page
33.

Caution: Make sure your computer and
synthesizer are powered off before making
these connections.

A standard printer cable connects the
MIDI Interface to the modem port
(recommended) or printer port on the
back of the Mac. The MIDI interface
functions as a high speed modem that
transmits data between the computer and
synthesizer. Two MIDI cables connect the
synthesizer to the MIDI interface. MIDI
cable connections go to opposite label
names. MIDI In on the interface is

connected to MIDI Out on the synthe-
sizer. MIDI Out on the interface is
connected to MIDI In on the synthesizer.
Audio Out from the synthesizer is
connected to your sound system. Refer to
your MIDI interface and synthesizer
manuals for additional information.

Now that you’ve completed the setup, it’s
time to play some notes on your synthe-
sizer to make sure everything works
correctly. Choose the Note Reading drill
in the Drill menu. Make sure that the
menu items Use MIDI and Use Sound in
the Sound menu are both checked. Play a
few notes on your MIDI synthesizer and
verify that the corresponding on-screen
keyboard keys highlight and that their
names appear in an answer box.

If you hear the sound, skip to page 15. If
not…

Troubleshooting MIDI Sound
• Make sure Use MIDI is checked in the

Sound menu.

• Make sure Use Sound is checked in the
Sound menu.

• Make sure your MIDI synthesizers and
sound source are plugged in, turned
on, and the volume is turned up.

• Make sure your MIDI cables are
connected properly. Connections go to
opposite label names. MIDI In on the
MIDI interface is connected to MIDI
Out on the synthesizer. MIDI Out on
the MIDI interface is connected to
MIDI In on the synthesizer.

• Use the piano instrument. Make sure
the MIDI channel settings on your
synthesizer match those on the Piano
page in the Preferences dialog. See
the Reference Manual, page 33.

• If you’re using a MIDI keyboard
controller to play an external sound
module, you’ll have to turn on the Use
MIDI Echo command found in the
MIDI Setup section of the Preferences
dialog. See the Reference Manual,
page 33.
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• If you’re using MIDI Manager or
OMS, you’ll have to make sure
they’re properly installed. We suggest
you start with MiBAC’s built in
driver. See the Reference Manual,
page 42.

• Read the FAQ in the Appendix of the
Reference Manual, pages 48-49.

Chapter 4, Sound, in the Reference
Manual discusses sound and MIDI in
detail.
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This section contains an overview of the
MUSIC LESSONS I program.

MENUS
There are ten menus in MUSIC LES-
SONS I.

Apple Menu
The first item in the Apple menu is About
MUSIC LESSONS I. Choosing this item
displays a dialog box containing the
version number, the registered user name,
and information about contacting MiBAC
Music Software.

File Menu
The File menu contains commands to
create, open, save, and print progress
reports, set user preferences, and quit the
program.

Edit Menu
The Edit menu contains the usual cut,
copy and paste commands. They are not
used in MUSIC LESSONS I.

Drill Menu
The Drill menu contains the twelve
MUSIC LESSONS I drills.

Level Menu
The Level menu refers to level of
difficulty. It is divided into two sections,
main and custom. The number of items in
the main section changes for each of the
twelve drills. The levels of difficulty in
the Main section range from easy to
difficult. The custom section stays the
same in each drill and lets you create,
save, and load four custom levels.

Clefs Menu
The Clefs menu lets you choose between
treble, bass, alto, tenor, or any combina-
tion of these clefs.

Instrument Menu
The Instrument menu lets you choose
between the piano, guitar, or alphabet
block instruments. This menu is disabled
in drills that don’t use an instrument.

Options Menu
The Options menu contains commands
that control your interaction with the
program, set the keys used for drills, and
reset your scores.

Sound Menu
The Sound menu contains commands to
use sampled sounds, QuickTime Musical
Instruments, MIDI, sound effects, change
MIDI instrument sounds, and change the
tempo.

Window Menu
The Window menu lets you switch
between Drill, Progress, and Help
windows.

Help Menu
The Help menu is shown as a question
mark icon at the far right of the menu bar.
It contains commands to turn balloon help
on and off, and to open the MUSIC
LESSONS I Help window.

CHAPTER 3 - OVERVIEW
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DRILLS
Two types of drills are used in the
program, instrument drills and multiple
choice drills. There are six of each.

Instrument Drills
Note Reading
Circle of Fifths
Five Finger Positions
Major/Minor Scales
Modes
Jazz Scales

Multiple Choice Drills
Key Signatures
Scale Degrees
Intervals
Note/Rest Durations
Scales Ear Training
Intervals Ear Training

INSTRUMENT DRILL
WINDOWS
Instrument drills display a piano, guitar,
or alphabet block instrument on the
screen. You answer questions by clicking
a key on the screen instrument or playing
a note on your MIDI synthesizer. Notes
you play on the synthesizer will be
highlighted on the screen keyboard. We’ll
use the term keyboard to refer to either
the on-screen MUSIC LESSONS I
instrument or an attached MIDI synthe-
sizer. The following picture shows an
instrument drill window displaying the
piano keyboard.

MULTIPLE CHOICE DRILL
WINDOWS
Multiple Choice drills display one or two
groups of answer buttons. You answer
questions by clicking the appropriate
button. The following picture shows a
multiple choice drill window.

SCREEN ELEMENTS
The following elements are common to
both instrument and multiple choice drill
windows.

Music Staff
The music staff displays a clef, key
signature, time signature, notes, and rests.
The exact symbols displayed depend on
the drill.

Score Area
The score area in the upper right corner of
the drill window shows your percentage of
correct answers, the number of correct
answers, and the number of questions
you’ve tried for each level of each drill.
As you change drills, levels, clefs, or
instruments, the score changes accord-
ingly.

Answer Boxes
Answer boxes are located below the
music staff. When you play the keyboard
or click an answer button, your answers
will appear in these boxes. If the Allow
Typed Answers menu command is
checked, you can also type your answers.
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Active Text Box
The active text box is the answer box that
contains the blinking text insertion point
or the highlighted text.

Instruction Text
Instruction text is located below or to the
left of the answer box(es) and provides
additional information needed to answer
the question.

Instrument / Answer Buttons
You answer questions by using the on
screen Instrument or Answer Buttons. In
instrument drills, clicking a note on the
screen keyboard or playing a note on your
MIDI keyboard will enter the note name
into the active text box. In multiple choice
drills clicking the appropriate answer
button will enter the answer into the
active text box.

TOOLBARS
Four toolbars are used in MUSIC
LESSONS I.

Drill Toolbar
The Drill toolbar appears in all drills and
contains thirteen buttons. The first twelve
correspond to the twelve MUSIC
LESSONS I drills. The last button is the
Help button that opens the MUSIC
LESSONS I Help window. The current
drill is indicated by a recessed appear-
ance, Note Reading in this picture.

Instrument Toolbar
The Instrument toolbar appears in the six
instrument drills. Its three buttons let you
change between the piano, guitar, and
alphabet block instruments.

You can control additional characteristics
of each instrument by using the Instru-
ment menu or the Piano, Guitar, and
Alphabet Block pages in the Preferences
dialog. See the Reference Manual, pages
33-35.

Accidental Toolbar
The Accidental toolbar appears in strict
answers mode in the three scales drills:
Major/Minor, Modes, and Jazz. Its five
buttons are used to spell note names
exactly.

Scale Degree Toolbar
The Scale Degree toolbar appears only in
the Scale Degree drill. Its three buttons let
you choose whether you want to refer to
scale degrees by their music theory
names, by their moveable do (solfege)
names, or by their numerical position in
the scale.
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INSTRUMENTS
In Instrument drills you can choose
between a piano, guitar or alphabet block
instrument. You switch between instru-
ments by clicking a button in the
Instrument toolbar, or by using the
Instrument menu.

Piano Instrument
You can use a four or six octave piano.
Use the Piano page of the Preferences
dialog to make your settings permanent.
See the Reference Manual, pages 33-34.

You play the piano instrument by clicking
a key on the screen or playing a note on
your MIDI synthesizer. The note you play
will be highlighted on the screen, and the
name will appear in the active answer
box.

Guitar Instrument
You can use a 12 or 19 fret guitar. In
addition, you can specify whether you
want the bass string to appear at the top or
bottom of the fingerboard picture. Use the
Guitar page of the Preferences dialog to
make your settings permanent. See the
Reference Manual, pages 34-35.

You play the guitar instrument by clicking
a fret position on the screen or playing a
note on your MIDI synthesizer. The note
you play will be highlighted on the screen
and the name will appear in the active
answer box.

Alphabet Block Instrument
The alphabet block instrument can display
accidentals using symbols or text. Use the
Alphabet Block page of the Preferences
dialog to make your settings permanent.
See the Reference Manual, page 35.

You play the alphabet block instrument by
clicking a letter block and an accidental
block on the screen, or by playing a note
on your MIDI synthesizer. The note you
play will be highlighted on the screen and
the name will appear in the active answer
box. Single clicking an alphabet block or
an accidental block enters the note into
the active text box. Type the tab key, right
arrow key, or click the right arrow icon to
advance to the next answer box. Double
clicking an alphabet block or an acciden-
tal block enters the note into the active
answer box and advances the text
insertion point to the next answer box.

KEYBOARD POPUP MENU
If you click a piano key, guitar fret, or
alphabet block and keep the mouse button
held down, a popup menu will appear that
lets you select the name of the note you
want to use for that key. The piano popup
menu is shown below.

SOUND
You can play sounds through the Mac
speaker or through a MIDI synthesizer. If
you use the Mac speaker you can choose
between sampled sounds or QuickTime
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Musical Instruments. If you use MIDI,
MUSIC LESSONS I supports MiBAC’s
built in MIDI routines, Apple’s MIDI
Manager, or Opcode Systems’ OMS
(Open Music System). You can change
settings in the Sound menu and in the
Preferences dialog. See the Reference
Manual, pages 32-33, for more detailed
information. See the Reference Manual,
page 53, for information on obtaining
QuickTime Musical Instruments, MIDI
Manager, and OMS.

ANSWERING QUESTIONS
MUSIC LESSONS I poses a question on
the screen. You answer it.

Instrument drills display a screen
instrument and have multiple answer
boxes.

Multiple Choice drills have one answer
box and one or two groups of answer
buttons.

There are three ways to enter your
answers.

Mouse Entry
In Multiple Choice drills, click the
appropriate answer button. In Instrument
drills, click a key on the screen instru-
ment.

MIDI Entry
In Instrument drills, play a note on your
MIDI synthesizer. The note you play will
be highlighted on the screen and the name
will be entered into the active answer box.
The only multiple choice drill that
supports MIDI entry is Key Signatures.

Typing Entry
If you want to type your answers, you
must turn on Allow Typed Answers from
the Options menu.

After you’ve entered your answers, click
the Check button and your score will be
updated.

FAST ANSWER CHECKING
When Fast Answer Checking is on,
MUSIC LESSONS I automatically checks
your answers as soon as all answer boxes
are filled. If your answers are correct
you’ll instantly get a new question. If any
answers are wrong, the first wrong answer
will be selected. When you’ve corrected
that answer, the next wrong answer will
be selected. As soon as you’ve corrected
all the wrong answers, your answer will
be checked again. Fast Answer Checking
is a rapid way to improve your skills in all
drills. Fast Answer Checking is found in
the Options menu and the General page of
the Preferences dialog. See the Reference
Manual, pages 23, 30.

SOUND EFFECTS
You can assign different sound effects to
be played for right and wrong answers
using the Sound Effects page of the
Preferences dialog. Make sure Use Sound
Effects in the Sound Menu is also
checked. See the Reference Manual,
pages 25, 37

BUTTONS
The Check, Next, Play, and Show Me
buttons appear in all twelve drills. Each
one has a typing shortcut. Typing
shortcuts are described as “Command-
M.” This means you press the command
key and type m. The command key is the
key with the Apple, propeller, or clover
leaf symbol. You can assign keys on your
MIDI synthesizer to function as shortcuts
for these buttons by using the MIDI
Shortcuts page of the Preferences dialog.
See the Reference Manual, page 47.

Check Button
Click Check (or type Enter) to evaluate
your answer. If your answer is correct a
diamond will appear above the answer
box. If your answer is wrong an X will
appear above the answer box. In most
drills, clicking the Check button will also
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play your answers. Your score is only
updated the first time you click Check, so
make sure you’ve entered the answer you
want. If you correct a wrong answer and
then click Check again, your score will
not be updated.

Next Button
Click Next (or type Command-N) for a
new question.

Play Button
Click Play (or type Command-P) to play
the correct answer. There’s a difference
between what the Check and Play buttons
play. Clicking Check plays your answer.
Clicking Play plays the correct answer.
Hopefully, they’ll be the same. The Play
button is disabled in the Key Signatures,
Scale Degrees, and Note/Rest Durations
drills.

Show Me Button
Click Show Me (or type Command-M) to
display the correct answer. Show Me will
highlight the correct keyboard key or
answer button. In most drills clicking the
Show Me button will play the correct
answer. If you click Show Me before you
click Check, your score will not be
updated.

CUSTOM LEVELS
You can create four custom levels in each
drill. The Level menu for each drill
contains these items.

The Set Custom Levels command opens a
dialog box where you create the four
custom drills. The Save Custom Levels
command saves the four custom levels of
the current drill. Load Custom Levels
opens and loads custom levels from a file
that was previously saved. The custom
levels currently in effect will be remem-

bered across program restarts.

SCREEN COLORS AND
FONTS
We’ve used default fonts, sizes, styles,
and colors for elements appearing on the
screen. If you don’t like our choices you
can change them by using the Color and
Font pages of the Preferences dialog. See
the Reference Manual, pages 31-32.

THE PROGRESS REPORT
WINDOW
The Progress Report window displays a
detailed listing of your scores. Progress
Reports are created and opened using the
New Progress Report and Open Progress
Report commands in the File menu.
Progress Report windows are divided into
two sections. The Date List in the upper
portion displays the dates of previously
saved program sessions. Click a date line
to display scores for that date in the lower
portion of the window. By saving your
scores to the same file, you can keep a
cumulative record of the growth of your
musical skills. In a classroom or studio
setting each student can have their own
progress report file. The number of
student files is limited only by disk space.
You could have thousands on a hard drive.
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PREFERENCES
The Preferences command in the File
menu allows you to customize the way
you use MUSIC LESSONS I. These
settings are saved in the MUSIC LES-
SONS I Preferences file located in the
Preferences folder inside the System
Folder and will be used whenever the
program is started.

The fifteen pages in the Preferences
dialog can be accessed by the Preferences
popup menu or by clicking the Prev and
Next buttons.

Click the OK button to set the program
preferences on the current page until you
quit the program. Settings will not be
saved across program restarts.

Click the Permanent button to save the
program preferences on the current page
to a file called “MUSIC LESSONS I
Preferences” in the Preferences folder
inside the System Folder. These settings
are used whenever the program is started.

Click the Defaults button to reset the
current page to MUSIC LESSONS I’s
default settings.

Click the Cancel button to exit from the
Preferences dialog without changing or
saving any settings.

Preferences are discussed in detail in
Chapter 3 of the Reference Manual.

GETTING HELP
Two forms of help are available, the
MUSIC LESSONS I Help Window and
Balloon Help.

MUSIC LESSONS I Help Window
A complete music theory reference is
available by choosing Help from the
Window menu,

clicking the Help button in the toolbar,

or choosing the MUSIC LESSONS I Help
command from the Help Menu.

We’ve supplied help files explaining the
music theory for all the drills in MUSIC
LESSONS I as well as instructions for
using the program. The following picture
shows the MUSIC LESSONS I Help
window.

The Help window is divided into three
parts. The File List in the lower left
displays the help files in the MUSIC
LESSONS I Help folder. When you click
a file name in the File List, the topics in
that file appear in the Topic List in the
upper left, and the contents of the file will
appear in the Contents area on the right.
When you click a topic in the Topic List,
that topic will scroll into view in the
Contents area.
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When you see a speaker button in the help
file, double click the speaker to play the
sound.

The MUSIC LESSONS I Help system is
extensible. You can create and add your
own files to the MUSIC LESSONS I Help
folder. Help files can be created with the
ML Help Editor application and are just
text files containing colored, styled text,
pictures, and sounds. Once you’ve created
a help file, just copy it to the MUSIC
LESSONS I Help folder, and it will show
up in the File List in the Help window.
See the Reference Manual, page 50, for
information on creating your own help
files.

Help files can be printed by choosing the
Print command in the File menu.

Balloon Help
Balloon Help is a standard feature in
System 7 and later. To activate Balloon
Help choose Show Balloons from the
Help menu.

When Balloon Help is on, balloons appear
when the mouse is moved over areas of
the screen. The following picture shows
the help balloon that appears when the
mouse is moved over the Help icon in the
Drill toolbar.

Balloon help is available for all menu
items, dialogs and drill windows in
MUSIC LESSONS I. Try it. Choose Hide
Balloons from the Help menu to turn
balloon help off.
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This section covers most of the program
features by concentrating on the Note
Reading drill. The lessons learned in this
section apply to the other eleven drills.
Many of the settings you experiment with
in this section can be changed and saved
using the Preferences command in the
File menu. See Part 7 Preferences, page
67.

This font indicates steps and experi-
ments to be tried at the computer.  You’ll
get the most out of this section by
working along at your computer as
you’re reading.

Throughout this manual we’ll refer to a
menu item as being on or off. The menu
item is on when a check mark appears
next to it. The menu item is off when no
check mark appears.

Changing Drills
You change drills by choosing items in
the Drill menu or clicking buttons in the
Drill toolbar. The order of drills in the
Drill menu is the same as the order of the
buttons in the Drill toolbar. The current
drill is indicated by a check mark in the
menu and by a recessed appearance in the
toolbar.

Choose different drills from the Drill
menu and observe the buttons in the
toolbar.  Click different buttons in the
Drill toolbar and observe the checked
item in the Drill menu.

Changing Clefs
You change clefs by choosing items in the
Clefs menu. You can use any combination
of treble, bass, alto, or tenor clefs by
choosing the Random Clefs menu item.

Choose different clefs from the Drill
menu and observe the music staff.
Choose Random Clefs from the Clefs
menu, and in the Random Clefs dialog
box, choose any combination of clefs.
Click OK.  Click the Next button a few
times and watch as the questions
alternate between the clefs you
specified.

Changing Instruments
You change instruments by choosing
items in the Instrument menu or clicking
buttons in the Instrument toolbar. You can
use a piano, guitar, or alphabet block
instrument.

Click each instrument button in the
Instrument toolbar and watch the
instrument change on screen.  If you

Chapter 4 - Tutorial
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change instruments from the Instru-
ment menu, you’ll have more choices.
You can use a four or six octave piano,
a 12 or 19 fret guitar, and have the
alphabet block instrument display
accidentals by symbol or name.  Try
each instrument variation.

There are additional instrument options
on the Piano, Guitar, and Alphabet Block
pages in the Preferences dialog. See the
Reference Manual, pages 33-35.

Playing Instruments
You play the screen instrument by
clicking a key on the screen. The notes
you play will highlight on the screen and
the note name will be entered into the
active text box.

Piano Instrument
Change to the piano instrument and
play a few notes.

Guitar Instrument
Change to the guitar instrument and
play a few notes.

Alphabet Block Instrument
You play the alphabet block instrument by
clicking a letter block and an accidental
block on the screen. Single clicking an
alphabet block or an accidental block
enters the note into the active text box.
Double clicking an alphabet block or an
accidental block enters the note into the
active answer box and advances to the
next answer box.

Change to the alphabet block instru-
ment and play a few notes using the
mouse.  Try single clicks and double
clicks.

If you have a MIDI synthesizer, the notes
you play on your synthesizer will
highlight on the screen instrument, and
the note names will be entered into the
active text box.

If you’ve connected a MIDI synthesizer,
play a few notes on your synthesizer
and watch the highlighting on all three
screen instruments.

Moving Between Answer
Boxes
Several drills have more than one answer
box. You can move between answer boxes
three ways. Try all three.

Press the tab key or right arrow key to
move to the answer box to the right.

Press shift-tab or left arrow key to move
to the answer box to the left.

Click in an answer box.

Answering Questions
There are three ways to enter your
answers in instrument drills.

Mouse entry
Click the keys of the screen instrument.
The names of the notes will be entered
into the active answer box.  The active
answer box is the one with the blinking
vertical text insertion bar.

MIDI entry
Play a few keys on your MIDI keyboard.
The notes you play will be highlighted
on the screen keyboard and their
names will be entered into the active
answer box.  See page 81 for informa-
tion on setting up your MIDI synthe-
sizer.

Typing entry
Turn Allow Typed Answers on in the
Options menu (has check mark).  Type
your answers.

Check, Next, Play, and
Show Me Buttons
These four buttons appear in all twelve
drills. Each one has a typing shortcut.
Typing shortcuts are described as
“Command- M.” This means you press
the command key and type m. The
command key is the key with the Apple,
propeller, or clover leaf symbol. You can
assign keys on your MIDI synthesizer to
function as shortcuts for these buttons by
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using the MIDI Shortcuts page of the
Preferences dialog. See the Reference
Manual, page 36.

Check Button
The Check button checks your answer,
updates your score, and in most drills
plays your answer.

Click the Check button.  Diamonds
appear above correct answers and X’s
above wrong answers.  A shortcut for
Check is typing return or enter.  Try it.

Next Button
The Next button gives you a new
question.

Click the Next button several times and
watch new questions appear.  A
shortcut for Next is typing Command-E.
Try it.

Play Button
The Play button plays the correct answer.
The Check button plays your answer.
Hopefully, they’ll be the same.

Click the Play button and listen to the
correct answer.  Enter some wrong
answers and click the Check button.
Hear the difference?  The Play button
plays the correct answer, the Check
button plays your answer.  A shortcut
for Play is typing Command-L.  Try it.

Show Me Button
The Show Me button displays the correct
answer by highlighting the keyboard keys
or answer buttons. In most drills it also
plays the answer. If you click Show Me
before you click Check, your score will
not be updated.

Click the Next button to get a new
question.  Now click the Show Me
button.  Watch the correct answers
appear.  Now click the Check button and
try to get credit for the answer.  You
can’t.  Your screen score will not
change.  A shortcut for Show Me is
typing Command-M.  Try it.

Checking Answers
Reset the menus as follows:

Drill menu / Note Reading
Level menu / Spaces, No Accidentals
Clef menu / Treble Clef
Instrument menu / Piano / 4 Octaves

Click the Next button until the notes on
the screen match the following picture.

Mouse or MIDI Answers
Using either mouse or MIDI, play the
four notes F A C E on the keyboard as
shown below and then click the Check
button.

If your answers are correct you’ll see a
diamond over all four answer boxes, the
diamonds will flash a few times, the
score will be updated, and you’ll get a
new question.

If an answer is wrong you’ll see an X
over the answer box with the wrong
answer(s) and the screen score will be
updated.

Click the Next button for a new question
and try it again.
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Typed Answers
When you want to answer questions by
typing, you must turn on the Allow Typed
Answers command in the Options menu,
but don’t do it just yet.

Verify that the Allow Typed Answers
command in the Options menu is
turned off (no check mark).  Type your
answers.  Use the tab key, or left and
right arrow keys, to move between
answer boxes.  When all four notes have
been entered, click the Check button.
Your correct answers will be marked
wrong.  The reason?  Allow Typed
Answers was not turned on.  Now turn
on Allow Typed Answers from the
Options menu (has check mark) and
click the Check button.  Your correct
answers will be accepted.

When Allow Typed Answers is on,
MUSIC LESSONS I doesn’t care if you
played the note in the correct octave, only
that you got the name right. When Allow
Typed Answers is off, both the note name
and octave position have to be correct.
You can make this setting permanent
using the General page in the Preferences
dialog. See the Reference Manual, page
30.

Score
The score area of the Drill window shows
your percentage of right to wrong
answers, the total number of correct
answers, and the total number of tries.

If you were watching your score on the
screen, you may have noticed that it is
only updated the first time you click
Check. If you correct a wrong answer and
then click Check again, your score will
not be changed. If you click Show Me
before you click Check, you will not get
credit for that question.

Click the Next button for a new ques-
tion.  Enter some correct answers and
some wrong answers and then click the
Check button.  Your score is updated.
The answer box with the first wrong
answer is selected.  Now correct your
wrong answers and click the Check
button again.  If you get them all
correct, you’ll get a new question, but
your score will not be changed.

Auto Next Note
The Auto Next Note command appears in
the Options Menu. When Auto Next Note
is on, the text insertion point advances to
the next answer box each time you play a
note. When you play several notes in a
row, notes are entered into successive
answer boxes. When Auto Next Note is
off, every note you play stays in the same
answer box, replacing the note previously
there. This menu command affects only
the current drill. It is disabled when using
the Alphabet Block instrument, or in drills
that have only one answer box. You can
set Auto Next Note independently for
each drill on the Drill page of the
Preferences dialog. See the Reference
Manual, page 31.

Turn Auto Next Note on (has check
mark).  Play several notes and watch
how they move from answer box to
answer box.  Turn Auto Next Note off
(no check mark).  Play several notes
and watch how they stay in the same
answer box.

Auto Next Question
The Auto Next Question command
appears in the Options Menu. When Auto
Next Question is on, each time you check
your answers and they are all correct,
you’ll be given a new question. When
Auto Next Question is off you will not get
a new question even if your answer was
correct. You can get a new question at any
time by clicking the Next button. This
menu command affects only the current
drill. You can set Auto Next Question
independently for each drill by using the
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Drill page in the Preferences dialog. See
the Reference Manual, page 31.

Turn Auto Next Question on (has check
mark).  Click Show Me and then click
Check.  When you get the answer right
you get a new question.  Turn Auto Next
Question off (no check mark).  Click
Show Me and then click Check.  When
you get the answer right you don’t get a
new question.

Correcting Mistakes
When MUSIC LESSONS I checks your
answers and they’re all correct, you’ll get
a new question. If any answers are wrong,
the first wrong answer will be selected.
When you’ve corrected that answer, the
next wrong answer will be selected.

In the Note Reading drill, choose
Spaces from the Level menu.  Turn on
Auto Next Note (has check mark) and
Auto Next Question (has check mark) in
the Options menu.  Click the Next
button until you get the question used
on page 25, “FACE.” Answer the
question, but this time deliberately get
notes two and four wrong.  Check your
answers.  The answer box for the first
wrong answer (note two) should be
highlighted.  Correct note two by
playing the correct answer.  The
highlighted answer box should advance
to the next wrong answer (note four).
Correct note four and click check.  If
your answers are now correct you’ll get
a new question.

Fast Answer Checking
In the Note Reading drill, Fast Answer
Checking is an excellent way to improve
your sight reading skills.

Choose the Note Reading drill, Spaces
level.  Play the correct notes.  Turn Fast
Answer Checking on in the Options
menu (has check mark).  As soon as
you’ve played the last note, MUSIC
LESSONS I will automatically check
your answers.  If they’re correct, you’ll
get a new question.  If you make
mistakes, the answer box with the first

mistake will be selected.  Correct that
mistake.  If that was the only one wrong
your answers will be checked again.  If
there is another mistake the next wrong
answer will be selected.

Use Sound
The Use Sound command appears in the
Sound menu. When Use Sound is on,
notes will be played when you click the
Check, Play or Show Me buttons. In some
situations you might want to turn the
sound off. For example, you’re working in
a public place and don’t want to disturb
others. Or you’re looking for faster
feedback and want the answers checked
instantly, without having to wait for each
note to play.

Turn Use Sound off (no check mark).
Answer some questions and check your
answers.  Notice how fast the answers
appear when sound is not used.  Turn
Use Sound on (has check mark).
Answer some questions, check your
answers and listen.

Use Sound Effects
The Use Sound Effects command is found
in the Sound menu. You can assign sound
effects, like applause and buzzer, to right
and wrong answers and have them played
after checking your answers.

Turn Sound Effects on (has check
mark).  Answer some questions and
listen to the sound effect after your
answers are checked.

If you don’t like the default sound effects
you can change them using the Sound
Effects page in the Preferences dialog.
See the Reference Manual, page 37.. You
can also create your own sound effects.
See the Reference Manual, page 51.

Set Tempo
The Set Tempo command in the Sound
menu changes how fast the answers play.
You can make answers play slowly so you
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have time to watch the notes highlight on
the screen. You can make answers play
fast so you get new questions more
quickly.

Choose the Set Tempo command from
the Sound menu.  In the Set Tempo
dialog box, drag the slider control to
change the tempo.  Choose a fast
tempo (230) and click the OK button.
Now click the Show Me button.  Try it
again with a slow tempo (60).  When
you’re done experimenting, reset the
tempo to 120.

Note Names
You can call notes by their alphabet
names C D E F G A B, or by their solfege
names Do Re Mi Fa Sol La Si.

Choose the Preferences command from
the File menu.  In the Preferences
dialog choose Drill from the popup
menu and select the Solfege radio
button in the Note Names section of the
dialog box.  Click OK.  See the Refer-
ence Manual, page 31.

Play some notes on the keyboard and
observe how the note names have
changed.  If you want to reset the note
names back to alphabet names do it
now.

Note Name Balloons
You’ve probably noticed the balloons that
appear above the keys of the screen piano
as your answers are being checked. You
can set the note name balloon behavior to
On Check and Show Me, Always, or
Never.

Choose the Preferences command from
the File menu.  In the Preferences
dialog choose Piano from the popup

menu, select the Always radio button
from the Display Name Balloons
section, and click OK.  See page 73.

Play some notes on the piano keyboard.
Balloons appear over each note you
play.  This setting is useful when you’re
learning to read notes.  Change the
setting to Never and play some more
notes — no balloons.  Reset the note
name balloons to the setting you prefer.

You can set the note name balloon
behavior for the guitar instrument by
using the Guitar page in the Preferences
dialog. See the Reference Manual, page
34.

Changing the Level of
Difficulty
Choose Note Reading from the Drill
menu. Look at the items in the Level
menu. You should see the following.

The Level menu for every MUSIC
LESSONS I drill is divided into two
sections: Main and Custom.

Main — Everything above Custom
    Level 1.
Custom — Everything from Custom

Level 1 down.

The number of groups and items in the
main section change for each drill. The
custom section remains the same.
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Choose other drills from the Drill menu
and look at the items in the Level menu.
When you’re done go back to the Note
Reading drill.

The Level menu for the Note Reading
drill has three groups in the main section.
The first group contains these items.

Spaces
Lines
Staff
Ledgers
Ledgers Only

The second group modifies items in the
first group.

No Accidentals
Single Accidentals
Double Accidentals

The third group modifies the Ledgers and
Ledgers Only items from the first group.
These items are disabled (grayed) until
you select Ledgers or Ledgers Only from
the main group.

Beginning Ledgers
Advanced Ledgers

Let’s explore the Level menu for the Note
Reading drill. Reset the menus as follows:

Drill menu / Note Reading
Clef menu / Treble Clef
Instrument menu / Piano / 4 Octaves
Level menu / Spaces / No Accidentals

Click the Next button a few times.  All
new questions will be notes on the
spaces of the staff.

Choose Lines from the Level menu.
Click the Next button a few times.  All
new questions will be notes on the lines
of the staff.

Choose Staff from the Level menu.
Click the Next button a few times.  All
new questions will be notes on the lines
and spaces within the staff.

Choose Ledgers from the Level menu.
Click the Next button a few times.  All
new questions will be notes on the lines
and spaces of the staff, and sometimes
on ledger lines above and below the
staff.

Choose Ledgers Only from the Level
menu.  Click the Next button a few
times.  All new questions will be notes
above or below the lines of the staff,
and no notes appear within the staff.

Let’s modify some of the levels in the
main group.

Choose Lines from the Level menu and
then choose Single Accidentals from
the Level menu.  Click the Next button a
few times.  All new questions will be
notes on the lines of the staff, and some
notes will have sharps or naturals in
front of them.

Choose Double Accidentals from the
Level menu.  Click the Next button a few
times.  All new questions will be notes
on the lines of the staff, some notes will
have sharps or naturals in front of them,
and some notes will have double
sharps in front of them.

Let’s work on the ledger lines.

Choose Ledgers Only, No Accidentals,
and Beginning Ledgers from the Level
menu.  Click the Next button a few
times.  All new questions will be notes
above or below the staff and no note
will be more than two ledger lines
above or below the staff.

Choose Advanced Ledgers from the
Level menu.  Click the Next button a few
times.  Notes below the staff range
down to five ledgers below, but notes
above the staff are restricted to two
ledgers above.  That’s because the four
octave screen piano cannot play notes
beyond that range.

Choose the six octave piano from the
Instrument menu to increase the range.

Click the Next button a few times.
Notes now appear up to five ledgers
above and below the staff.

Probably the hardest level in the Note
Reading drill is Ledgers Only,  Double
Accidentals,  6 Octave Piano,  Tenor
Clef.  Try it.
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Creating Your Own Drills
You can create four custom levels in each
drill. The Level menu for each drill
contains these items..

Let’s create some custom levels. Our first
custom level will be used to learn the
notes C to G in the bass clef.

Choose Set Custom Levels from the
Level menu.  When the Custom Levels
dialog box appears, enter information in
the dialog so that it matches the
following picture.

Clef = Bass
Accidentals = None and Flat
Range Bounds = C2 - G2

Click the Set Custom Level 1 Name
button and name this custom level “C2-
G2 Bass Clef with Flats.”  When you’re
finished click OK.  Now go back to the
Level menu.  The menu item that used
to be called Custom Level 1 is now
called C2-G2 Bass Clef With Flats.
Choose the C2-G2 Bass Clef With Flats
menu item and then click the Next
button a few times.  Observe that all
questions are in the bass clef using the
notes C2-G2, using no accidentals or
flats.

Our second custom level will be used for
practicing note reading on ledger lines
above the treble clef. We’ve already used

custom level 1, so we’ll make this Custom
Level 2.

Choose Set Custom Levels from the
Level menu.  When the Custom Levels
dialog box appears it will probably be
set to Custom Level 1, as you can see
by reading the button title in the upper
right corner.  Click the “Next>>” button
until the button title reads Set Custom
Level 2 Name.  Enter information in the
dialog so that it matches the following
picture.

Clef = Treble
Accidentals = None
Range Bounds = A4 - B5

Click the Set Custom Level 2 Name
button and name this custom level
“Treble Clef Ledgers Above Staff.”
When you’re finished, click OK.  Now go
back to the Level menu.  You should see
that the item that used to be called
Custom Level 2 is now called Treble
Clef Ledgers Above Staff.  Choose the
Treble Clef Ledgers Above Staff menu
item.  This custom level needs the six
octave piano, so MUSIC LESSONS I will
switch to that instrument.  Click the
Next button a few times and observe
that all new questions are in the treble
clef using the notes A4-B5, with no
accidentals.  When you switch back to
another level the default piano will
return.

Save/Load Custom Levels
You can save custom levels using the Save
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Custom Levels menu command and reuse
them later using the Load Custom Levels
command. Each custom level file contains
information for one drill. You can create
and save as many custom level files as
you want.

Choose Save Custom Levels from the
Level menu.  When the Save File dialog
appears, name the file “NN Custom
Week 1” and click Save.

Let’s change Custom Level 1 to demon-
strate two more aspects of custom levels.

• Custom levels currently in effect
are remembered across program
restarts.
• Opening custom level files.

Choose Set Custom Levels from the
level menu.  When the Custom Levels
dialog appears, change the options for
Custom Level 1 to:

Clef = Tenor
Accidentals = None
Range Bounds = D2 - D3

Click the Set Custom Level 1 Name
button and name this custom level “D2-
D3 Tenor Clef.”  When you’re finished,
click OK and go back to the Level menu.
The first custom level is now called D2-
D3 Tenor Clef.  Try it and then quit by
choosing Quit from the File Menu.  If the
Save Scores dialog appears click the
Don’t Save button.  See page 35.

Restart MUSIC LESSONS I and go back
to  the Note Reading drill.  The first
custom level in the Level menu should
still be called D2-D3 Tenor Clef..  That’s
the custom level that was in effect when
we quit.

Choose Load Custom Levels from the
Level menu.  When the open file dialog

appears open the file “NN Custom Week
1” file that we saved earlier.

Another dialog will appear asking for
confirmation prior to replacing custom
levels.

Click Load.  The four custom levels that
were in effect are now replaced by the
ones found in the file.  The Level menu
item in the Custom Level 1 position
should be C2-G2 Bass Clef With Flats.
If you quit and restart MUSIC LESSONS
I, the NN Custom Week I custom levels
will be in effect.

Score
The score shown on the screen is specific
to the drill, level, clef, and instrument
you’re working with. In the Note Reading
drill, a correct answer is worth four
points, one point for each note. In all
other drills a correct answer is worth one
point; the question was either right or
wrong.

Answer questions in different drills,
levels, clefs, and  instruments.  Notice
how the score on the screen reflects the
score for that specific drill.  As you
switch between different levels, clefs
and instruments, the score is updated
to reflect that specific combination.

Reset Scores
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Sometimes you get off to a bad start and
just want to start a drill over again.

Choose Reset Scores from the Options
menu.  The Reset Scores dialog lets you
reset scores for the current level of the
current drill (Reset Level), all levels of
the current drill (Reset Drill), or all
levels of all drills (Reset All).  Whichever
one you choose affects only scores that
have not been saved and will not
change any previously saved scores.

Choose Cancel.  Your session scores
have not been changed.

Help
A complete music theory reference is
available by choosing Help from the
Windows menu, clicking the Help button
in the toolbar, or choosing the MUSIC
LESSONS I Help command from the
Help Menu. See page 21.

We’ve supplied help files explaining the
music theory for all the drills in MUSIC
LESSONS I as well as instructions for
using the program. When you click the
Help button in the toolbar, the Help
window will open to the theory page for
that drill.

Click the Help button in the toolbar.  The
Help window will appear.

The Help window is divided into three
parts. The File List in the lower left
displays the help files in the MUSIC
LESSONS I Help folder. When you click
a file name in the File List, the topics in
that file appear in the Topic List in the
upper left, and the contents of the file will
appear in the Contents area on the right.
When you click a topic in the Topic List,
that topic will scroll into view in the
Contents area.

Click different file names in the File List.
Click different topics in the Topic List in
the upper left.

Help windows remember their position
when they’re closed and reopened.

Click and drag the grow box in the lower
right corner of the Help window to
change its size.  Click and drag the title
bar at the top of the window and move it
to another location.  Drag the “splitter”
bars to resize the sections.  Now close
the window and open it again. It should
appear in the state it was last in.

The MUSIC LESSONS I Help system is
extensible. You can create and add your
own files to the MUSIC LESSONS I Help
folder. Help files can be created with the
ML Help Editor. They’re text files
containing colored, styled text, pictures,
and sounds. Any help file copied into the
MUSIC LESSONS I Help folder and will
show up in the File List in the Help
window.  See the Reference Manual,
page50,  for information on creating help
files.

Help files can be printed by choosing the
Print command in the File menu. Take
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some time to familiarize yourself with the
contents and scope of the Help window.

Progress Reports
Progress Reports display a detailed listing
of your scores.

Answer at least one question from any
level of the Note Reading drill.  Choose
the New Progress Report command
from the file menu.  When the Name
dialog appears, type in your name and
click OK.

A new untitled Progress Report window
will appear showing the drills you’ve
done since MUSIC LESSONS I was
started, or since you last saved your
scores. Progress Report windows are
divided into two sections. The upper
section lists the dates that you’ve used
MUSIC LESSONS I and saved your
scores to this file. The lower section
displays the scores for the selected date.
Because we haven’t saved this Progress
Report, there is only one line in the upper
section — Session Scores. The name you
typed in the Name dialog appears under
the divider line in the window. Your
scores will probably be different from
those shown below.

Save your scores by choosing the Save
As command from the File menu.  Name
the file.  Navigate to the folder you want
to save the file to, and click the Save
button.

When the Description dialog appears,
type a short phrase describing the drills
you’ve done and click OK.

When the Progress Report window
reappears, there are three lines in the
upper section of the window: Session
Scores; Cumulative Scores; and a
highlighted line showing today’s date,
followed by the description you just
typed. We’ll experiment with these items
in a moment, but for now just close the
Progress Report.

Close the Progress Report window by
clicking the close box or by choosing
Close from the File menu.

Let’s do a different drill.

Choose Key Signatures from the Drill
menu.  Because we’re illustrating
features of the progress report, it
doesn’t matter if you get the question
right or wrong.  If you know the answer,
click the correct answer button and
then click the Check button.  If you
don’t know the answer, just click the
Check button.

Let’s’ take another look at our progress
report.
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Choose Open Progress Report from the
File menu and open the progress report
you just saved.

When the Progress Report window opens,
the Cumulative Scores line will be
highlighted. Cumulative Scores contain
the grand total of all scores saved in the
file. Because we haven’t saved the Key
Signatures scores they don’t appear in the
Cumulative Scores yet. They do, however,
appear in the Session Scores.

Click the Session Scores line.  You’ll
see the Key Signature scores.

To add the Key Signature scores to the
cumulative scores, we need to save the
file.

Choose Save from the File menu.  Click
the third line in the upper section of the
window.

The highlighted line now shows both the
Note Reading and Key Signature scores.
However, the descriptive text we added
earlier doesn’t reflect the Key Signature
scores. Let’s change the descriptive text.

Press the Option Key and click the first
date line (the third line in the preceding
picture).  When the Description dialog
appears, type “Note Reading-Key Sigs.”

Click the Session Scores line; you’ll
notice that the scores are now empty.
That’s because when we saved the file,
the session scores were merged into
the cumulative scores, and a new
session was started.

Right now the Cumulative Scores and the
Date Scores are identical, because this is
the first day you’ve saved to this file.
Every new day you save to this file, that
date will be added to the Date List in
upper section of the window. Clicking on
any one of these dates will display the
scores for that day. The following picture
shows a Progress Report with many dates.
The Date List always displays Session
Scores and Cumulative Scores followed
by any number of date lines. The scroll
bar will be activated when there are more
dates in the Date List than can fit in the
space. You can use the scroll bar to see all
the dates. You can also drag the “splitter”
to change the height of the score list.
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To recap:

• Session Scores displays the drills
you’ve done since you last saved.

• Cumulative Scores displays the total
scores of all drills, for all dates, in the
file.

• Date Scores display the drills done on
any one day.

The following picture illustrates the
information that appears in the progress
report.

Progress Report windows remember their
position when they’re closed and
reopened.

Click and drag the grow box in the lower
right corner of the Progress Report
window to change its size.  Click and
drag the title bar at the top of the
window and move it to another location.
Drag the “splitter” bar to resize the Date
List.  Now close the window and open it
again. It should appear in the state it
was last in.

Customize Progress
Reports
You can change the text colors used in the
Progress Report window.

Choose Preferences from the File menu.
When the Preferences dialog opens,
select Progress Report from the
Preferences popup menu.

Click a color rectangle to set the color
for that text element.  A representative
display of your choices is shown in the
lower left of the dialog.  Change some
of the text colors and reopen the
Progress Report.

Printing a Progress Report
If you have a color printer, and want to
print in color, select Color. Otherwise,
select Black & White. If you select Color
on a black and white printer you may get
unexpected results.

When you choose the Print command in
the File menu, the scores showing in the
lower portion of the Progress Report
window will be printed. You can print
your session scores, cumulative scores, or
scores for any date. If you did every level
of every drill in every clef and printed the
cumulative scores, the report would be
over 50 pages long.

Open the Progress Report you’ve been
working with and print your scores.
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Quitting MUSIC LESSONS I
When you choose Quit from the File
menu and there are scores that have not
been saved, a dialog box will appear
giving you four choices.

Existing File
Opens the Open File dialog where you
can select the Progress Report file to save
the scores to. See page 35.

New File
Opens the New File dialog where you can
create a new Progress Report file. See
page 34.

Cancel
Return to MUSIC LESSONS I.

Quit
Quit without saving.

Click the Next button for a new ques-
tion.  Click Check so you have at least
one unsaved score.  Choose Quit from
the File menu.  Experiment with the
different choices.
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